Resultat 1 till 15 av 15

Ämne: Ny CIM vill ej giftas in. Remove/Place key 3-4 gånger

  1. #1
    Sugmotor
    Reg.datum
    maj 2019
    Inlägg
    10
    Medlem#
    -

    Ny CIM vill ej giftas in. Remove/Place key 3-4 gånger

    Hej på er,

    Har lite problem med att gifta in en CIM-modul på en NG9-3 och skulle behöva lite hjälp ifall någon varit med om något liknande.

    Det är en ny* CIM med tillhörande nyckel som ska giftas in. Jag tar mig förbi frågorna som kommer upp, (årsmodell, modelltyp, market etc) och känns som att just när programmeringen är påväg att bli klar så säger den Remove Key, Place Key, Remove key, Place key säkert 3-4 gånger innan det tillslut kommer upp "Add/Remove ECU Failed". Varför?

    Har gift bort den gammla CIMen innan jag satte dit den nya. Batterispänningen är runt 12.9V under programmeringen. Har även rensat alla CIM relaterade felkoder som kom när jag satte dit den nya. Förstår inte vad det sitter i. Tech2-klonen som jag använder fungerar uppenbarligen då jag kunnat gifta in och ur andra moduler och har självklart Security Access från TIS2000.


    *Bättre begagnad beställd via nätet med tillhörande nyckel.

    Har som kört fast så hade uppskattat om någon har nån bra idé!

  2. #2
    Individuell mappning
    Reg.datum
    maj 2003
    Ort
    Trollhättan
    Inlägg
    8 557
    Medlem#
    6973
    Något med nyckelmatchningen strular. Kunde din gamla CIM läsa nyckeln korrekt så är det inget fel på tändningslåset ISM iaf, utan det lutar åt att den ”nya” CIMen inte kan läsa nyckeln korrekt. Jag bytte nyligen en CIM av just den anledningen, fjärr funkade men CIM hittade inte nyckeln när den stoppades i tändningslåset.
    9000 A50 2.0t -97 bruksbilen
    9000 CSE 2.3T -95 pysselbilen
    9000 -85 projektet som spelar död

  3. #3
    Sugmotor
    Reg.datum
    maj 2019
    Inlägg
    10
    Medlem#
    -
    Nyckeln jag använder under ingiftning är den som följde med CIMen, borde alltså inte vara den som är orsaken. Går det att kontrollera på något sätt? Ifall CIMen känner igen nyckeln eller ej?

    Kan tillägga att jag även bytt SCL. Skickade den gamla till en firma som klonade över och skickade tillbaka en ny. Har provat gifta in den också den det blir samma fenomen som med CIMen.

    Grundproblemet är att bilen inte startar. Har läst ut felkod B1445 01 Trigger Circuit CIM-SCL, Open/Short to B+.
    Har gått igenom samtliga åtgärder för detta larm enligt WIS, vilket är att kontrollera kablage och därefter byta SCL. Då det inte löste problemet köpte jag en ny CIM, men kan som sagt inte gifta in den.

  4. #4
    Steg 2 Turbo_Dannes avatar
    Reg.datum
    mar 2006
    Ort
    Stockholm Värmdö
    Inlägg
    2 558
    Medlem#
    6901
    Men det kanske är så "enkelt" som att det är en kabel som är kortsluten eller har avbrott i sig , då lär det inte gå att lära in en ny CIM heller.

    Snabb googling av felkoden gav en beskrivning och ett schema, vet inte hur detta stämmer med din bil men det borde finnas i WIS också, börja mät så att allt verkar schysst innan

    http://z90.pl/saab/dtc/read.php?model=9440&doc=IDA13457
    Polestar 2 Dual Motor Long Range -22
    Mercedes SL500 R230 -02

  5. #5
    Individuell mappning
    Reg.datum
    maj 2003
    Ort
    Trollhättan
    Inlägg
    8 557
    Medlem#
    6973
    Fast kan du inte gifta in SCL så har du ju felet där. Om du har tillgång till tech2 och säkerhetsaccess så finns det ingen vits med att låta klona SCL. Fixa en annan SCL som det inte har kluddats med.
    9000 A50 2.0t -97 bruksbilen
    9000 CSE 2.3T -95 pysselbilen
    9000 -85 projektet som spelar död

  6. #6
    Steg 3
    Reg.datum
    aug 2009
    Inlägg
    3 516
    Lyckades du klara ut exakt vad felet var som orsakade B1445 01? Om det t ex är backat stift eller hylsa i kabelns kontaktdon så lär det inte hjälpa att byta SCL eller CIM. Dessa fel är vanliga på ng9-3. Även kortslutna kablar eller avbrott inne i en kabel förekommer. Dessa fel kan vara tillfälliga och därmed svåra att identifiera.
    9-3 Aero 2000, 9-3 Aero SS 2005, BMW R1100RS 1993, tidigare 9000 CDi 1989, 900i 1985, 96 V4 1972

  7. #7
    Steg 2 Turbo_Dannes avatar
    Reg.datum
    mar 2006
    Ort
    Stockholm Värmdö
    Inlägg
    2 558
    Medlem#
    6901
    Fast har man en felkod på Open/short to B+ så hade iaf jag velat göra någon typ av mätning av kablage och spänning för att se så att allt verkar vara rätt innan jag börjar byta saker. Men jag kanske är annorlunda.
    Polestar 2 Dual Motor Long Range -22
    Mercedes SL500 R230 -02

  8. #8
    Steg 3
    Reg.datum
    aug 2009
    Inlägg
    3 516
    Jo, det blir oftast billigare så
    9-3 Aero 2000, 9-3 Aero SS 2005, BMW R1100RS 1993, tidigare 9000 CDi 1989, 900i 1985, 96 V4 1972

  9. #9
    Sugmotor
    Reg.datum
    maj 2019
    Inlägg
    10
    Medlem#
    -
    Har som sagt gått igenom åtgärderna för B1445 01 enligt WIS vilket är som du säger att kontrollera kablage och kontakter. Hittade då att det var jordfel på B+ till SCL (pin 1). Drog då en separat kabel direkt från + på batteriet med en 15amp säkring då det är väldigt bökigt att komma åt baksidan på säkringarna i instrumentpanelen dit den riktiga kabeln går.
    Senast redigerat av edwajn den 2022-08-08 klockan 18:34.

  10. #10
    Steg 5
    Reg.datum
    feb 2006
    Ort
    Torpshammar
    Inlägg
    5 912
    Fast hur menar du med "jordfel" på en B+ kabel? Om felet vore åtgärdat skulle ju felkoden försvinna. Det här är ju nackdelen med NG9-3 och dess nycker och felkoder och cim och allting. Man måste gå till botten med allt innan man börjar försöka byta grejer på vinst och förlust.
    Har du rätt cim då för det låter ju som du har en begagnad?

  11. #11
    Sugmotor
    Reg.datum
    maj 2019
    Inlägg
    10
    Medlem#
    -
    Testade att sätta tillbaka gamla CIMen då jag inte kunde gifta in den nya men det blev bara ännu värre. Så fort jag försökte adda den eller någon annan modul eller göra någon typ av programmering med Tech2:an fick jag upp felmeddelande "Negative Response: 7F 1A 22" samt en enorm mängd med felkoder som inte gick att ta bort. Satte då dit den nya CIMen och rensade felkoderna igen. Har nu 6 felkoder aktiva varav 5 av de har med belysning och sätesvärmare att göra, alltså högst irrelevanta. Den sjätte är B1001 67 CIM not added.

    Blir dock fortfarande samma fenomen när jag försöker adda CIMen. Remove key...Place key....Remove key...Place key.......Failed.

    Kan det vara som Hyvens säger att det är SCLen som orsakar det? Eller att den nya CIMen är kass...
    Senast redigerat av edwajn den 2022-08-08 klockan 18:34.

  12. #12
    Sugmotor
    Reg.datum
    maj 2019
    Inlägg
    10
    Medlem#
    -
    Citat Ursprungligen postat av StefanM Visa inlägg
    Fast hur menar du med "jordfel" på en B+ kabel? Om felet vore åtgärdat skulle ju felkoden försvinna. Det här är ju nackdelen med NG9-3 och dess nycker och felkoder och cim och allting. Man måste gå till botten med allt innan man börjar försöka byta grejer på vinst och förlust.
    Har du rätt cim då för det låter ju som du har en begagnad?
    Mätte mellan stift 1 på kontakten till SCL vilket är B+, mot +pol på batteriet. Visade då över 12V alltså ligger den kabeln mot jord någonstans då det egentligen ska visa 0V. CIM:en som jag kallar "nya" är inte splitter ny utan köpt begagnad med tillhörande nyckel från en relativt pålitlig reservdelssida.

    Håller med om att man måste gå till botten med allt, har blivit lite snurrig i huvudet från all googling och felsökning så ska ta och mäta om samtliga trådar som går till/från CIM,SCL & ISM ifall jag missat något. Kommer med uppdatering när det är gjort.

  13. #13
    Steg 1 Norrbagges avatar
    Reg.datum
    apr 2013
    Ort
    Tromsø
    Inlägg
    1 943
    En par-tre "reminders" når du tar gjennomgangen:

    - CIM og SCL er gift med hverandre, en ny enhet må giftes med den andre og en enhet som skal brukes i en ny bil må først skilles fra donor;

    - Du har ikke nevnt årsmodell for denne bilen, men om den (tilfeldigvis ) er MY2003 så finner du at i WIS under bytte av SCL er det en "Observera" som gjelder serienummer på bilen, PN på SCL og CIM programversjon i forhold til dette.

    - DTC B1445 01 gjelder åpen ev. kortsluttet triggerledning mellom CIM-SCL.
    Saab 9-3 SC Aero 2.0T XWD/eLSD Aut. 2009. eSID2

  14. #14
    Steg 4 GlennBs avatar
    Reg.datum
    dec 2006
    Ort
    Norr om sthlm
    Inlägg
    4 160
    Medlem#
    12120
    Citat Ursprungligen postat av edwajn Visa inlägg
    Mätte mellan stift 1 på kontakten till SCL vilket är B+, mot +pol på batteriet. Visade då över 12V alltså ligger den kabeln mot jord någonstans då det egentligen ska visa 0V.
    Det där blev snurrigt, om den ska vara ansluten till B+ så ska den ju visa 12V (ja, eller lite drygt då) , hur kommer jord in i bilden ? skulle den ligga mot jord skulle det ju troligen brinna en säkring och vara 0V ?

    Jag fattar inte.
    Nu: SAAB 9-5 Aero '07, SAAB 9-5 Aero SC '05, SAAB 9-5 2.0t '99 (Skrotas/säljs dessvärre trots återupplivandet.. ) ..Nu med Tech2.

    Då: SAAB 900 turbo '83, SAAB 9000i '92, SAAB 9000CDE 2.3t '96, SAAB 9-5 2.3t '01

  15. #15
    Steg 5
    Reg.datum
    feb 2006
    Ort
    Torpshammar
    Inlägg
    5 912
    Citat Ursprungligen postat av edwajn Visa inlägg
    Mätte mellan stift 1 på kontakten till SCL vilket är B+, mot +pol på batteriet. Visade då över 12V alltså ligger den kabeln mot jord någonstans då det egentligen ska visa 0V. CIM:en som jag kallar "nya" är inte splitter ny utan köpt begagnad med tillhörande nyckel från en relativt pålitlig reservdelssida.

    Håller med om att man måste gå till botten med allt, har blivit lite snurrig i huvudet från all googling och felsökning så ska ta och mäta om samtliga trådar som går till/från CIM,SCL & ISM ifall jag missat något. Kommer med uppdatering när det är gjort.
    nja så enkelt är det inte att mäta. Man kan absolut få "jord" genom elektronik utan att det är nå fel för det. Ska man mäta som du gör så måste man koppla loss den i bägge ändar och se den som isolerad. Har du då jord på den så är det ju nå fel såklart.........

Liknande ämnen

  1. [LÖST] Måste en dörrmodul giftas ur? Ng9-3
    Av Murkas i forum Ljud och elektricitet
    Svar: 8
    Senaste inlägg: 2019-09-14, 17:15
  2. [LÖST] Måste ny SID-display giftas in? OG9-5 / OG9-3
    Av -big kahuna- i forum Ljud och elektricitet
    Svar: 5
    Senaste inlägg: 2012-05-04, 10:14

Behörigheter för att posta

  • Du får inte posta nya ämnen
  • Du får inte posta svar
  • Du får inte posta bifogade filer
  • Du får inte redigera dina inlägg
  •