Resultat 1 till 14 av 14

Ämne: Avgasknallar efter start av varm motor OG9-5 B2x5

  1. #1
    Sugmotor
    Reg.datum
    mar 2009
    Inlägg
    20

    Avgasknallar efter start av varm motor OG9-5 B2x5

    När motorn är genomvarm och främst under varm årstid vid start inom några minuter kommer ibland några kraftiga smällar men ingenting därefter. Låter som förr i tiden med gamla fallförgasare som efter full gas och snabb uppsläpp av gaspedalen sände lite oförbränt bränsle ut i avgassystemet. Tillfrågad verkstad vet ej. Inga felkoder. Detta händer även om bilen står stilla och alltså motorn går på tomgång utan extra gas. Normal bensinförbrukning. Regelbunden service. Gäller 9-5 Aero -07 med automat, 30 000 mil. Avgassystem Ferrita hela vägen. Nu påstår verkstadskunnig att det gått hål på systemet! Min fråga: finns det någon sensor eller annat system som reglerar bränslemängden vid start av kall eller varm motor?????
    Janne

  2. #2
    Steg 6
    Reg.datum
    feb 2005
    Ort
    Stockholm
    Inlägg
    6 722
    Medlem#
    8758
    Har du möjligen en pirat tändkassett? Det är känt att vissa av dem (som det ser ut som) avsiktligt döljer misständningar.

    Smällarna kommer i avgassystemet, ingen annanstans om jag tolkar dig rätt?

    Vid start skickar insprutningen ut extra bränsle de första 30.sekunderna för att tända katalysatorn (extra koloxid), men detta ska inte kunna ge smällar i avgaset om allt annat är rätt.
    9-5 2.3t SC 2000, 55000+ mil
    9000 CSE 2.3T -93
    9000 CSE 2.3t -96

  3. #3
    Sugmotor
    Reg.datum
    mar 2009
    Inlägg
    20
    Tändkassetten byttes för ca 10 000 mil sedan av en seriös verkstad med gedigna SAAB-kunskaper. Luftmassemätaren byttes för ca 2000 mil sedan. Mina problem har uppstått under de sista 1000 milen. Det finns inga kraftförluster i motorn eller ryck som kan indikera tändkassetten vad jag kan förstå. Smällarna är likadana vare sig motorn går på tomgång eller driver växellådan. Smällarna upphör inom en minut, vilket stämmer med de angivna 30 sec. Och aldrig med kall motor.

  4. #4
    Steg 6
    Reg.datum
    feb 2005
    Ort
    Stockholm
    Inlägg
    6 722
    Medlem#
    8758
    Är avgassystemet tätt innan katalysatorn, kanske får man in rjuvluft (framför allt sitter katalysatorn ordentligt skruvad i turbon, har haft problem med dock inte några smällar).

    Man kan slå av extra bränsle med T7Suite.
    9-5 2.3t SC 2000, 55000+ mil
    9000 CSE 2.3T -93
    9000 CSE 2.3t -96

  5. #5
    Steg 3
    Reg.datum
    jan 2003
    Ort
    Norrköping
    Inlägg
    3 748
    Medlem#
    10798
    Citat Ursprungligen postat av Långmilare Visa inlägg
    Har du möjligen en pirat tändkassett? Det är känt att vissa av dem (som det ser ut som) avsiktligt döljer misständningar.

    Smällarna kommer i avgassystemet, ingen annanstans om jag tolkar dig rätt?

    Vid start skickar insprutningen ut extra bränsle de första 30.sekunderna för att tända katalysatorn (extra koloxid), men detta ska inte kunna ge smällar i avgaset om allt annat är rätt.
    Det är tändningen man senareställer i kombination med förhöjd tomgång för att höja avgastemperaturen. Extra bränsle utan någon annan åtgärd skulle inte tillföra någonting.

    För att det ska smälla så räcker det inte med bränsle utan det måste till luft också, ex.på grund av misständningar.

  6. #6
    Sugmotor
    Reg.datum
    mar 2009
    Inlägg
    20
    Men om tändningstidpunkten ändras hur påverkas effektkurvan? Motorn går utmärkt, startar direkt, accar bra och kommer snabbt över 240 km/h på Autobahn, kan gå i timmar över 200 km/h. En förhöjd tomgång påverkar väl även växellådan vid stillastående?

  7. #7
    Steg 3
    Reg.datum
    jan 2003
    Ort
    Norrköping
    Inlägg
    3 748
    Medlem#
    10798
    Citat Ursprungligen postat av jannes Visa inlägg
    Men om tändningstidpunkten ändras hur påverkas effektkurvan? Motorn går utmärkt, startar direkt, accar bra och kommer snabbt över 240 km/h på Autobahn, kan gå i timmar över 200 km/h. En förhöjd tomgång påverkar väl även växellådan vid stillastående?
    Funktionen är bara aktiv de första 1000-3000 förbränningarna under förutsättningen att kylvätsketemperaturen ligger mellan -10 och 64 grader vid start.

    https://saabwisonline.com/c10/9-5/20...ting-ignition/

    Börja med att kolla misständningar med hjälp av Tech2 skulle jag säga, troligtvis så har du tändningsmissar som orsakar smällarna. Att det inte smäller i samband med kallstart kan ju bero på att avgassystemet då är för kallt för att antända bränslet som släpps igenom.

  8. #8
    Steg 1
    Reg.datum
    dec 2010
    Ort
    Holmsund
    Inlägg
    1 545
    Jag har felsökt olika problem i hela mitt liv men i 99% av fallen när man blir för "djup" i diagnosen så är ofta felet mycket enkelt.
    Börja med att kolla dom mesta vitala sakerna, sannolikheten att man har ett fel som inte är modellspecifikt är lågt.
    Vet du att knallarna är från avgassystemet och inte från insuget?
    När du startar den varm finns det då misständingar (går på 3 cylindrar) eller går den helt jämnt innan det börjar.
    Har du tändstift NGK av rätt modell?
    Är vevaxelsensorn (CPS) någon gång bytt?(billiga kinesiska modeller beter sig mysko)
    Eftersom felet inte speciellt vanligt så gissar jag på något som redan är bytt där man valt dåliga komponenter.

    1 användare gillar detta inlägg



  9. #9
    Steg 6
    Reg.datum
    feb 2005
    Ort
    Stockholm
    Inlägg
    6 722
    Medlem#
    8758
    Jo, problemet låter väldigt udda för en Trioninic-bil. Så, frågan om dåliga reservdelar är högst relevant, speciellt vevaxelgivaren.

    Smällarna kommer ju sannolikt som en funktion av att det tänder på fel ställe, i någon bemärkelse.

    Enstaka misständningar på tomgång eller gasuppsläpp kan vara lätta att missa. Och de ger normalt inte någon felkod heller.

    Jag skulle nog ändå börja med att prova en annan tändkassett först, eftersom det är så enkelt och dålig tändkassett är en möjlighet. (Nu utgår jag från att det är en originalkassett som sitter där, eftersom den som sitter där gått 10k mil, så skulle det förvåna mig rejält om det är en pirat - är det å andra sidan mot förmodan en pirat är åtminstone ett fel hittat.)

    Det är ju en möjlighet att den tänder i fel takt pga den lyckats identifiera kamläget genom att titta på vilka cylindrar det tänder i, men detta borde definitivt ge felkoden P0340. I det fallet ger den bensin och gnista även när den är i fel takt - men som sagt borde inte kunna undvika felkod P0340.

    Detta leder till en annan fråga, sitter det rätt tändstift i (NGK PFR6H-10), och hur ser dom ut? Samt se de likdant slitna ut i alla cylindrar?
    9-5 2.3t SC 2000, 55000+ mil
    9000 CSE 2.3T -93
    9000 CSE 2.3t -96

  10. #10
    Sugmotor
    Reg.datum
    mar 2009
    Inlägg
    20
    När det händer så är det inte alltid utan slumpvis men alltid vid återstart av varm motor när det är varmt ute. Som regel kommer det två st knallar efter varandra med ca 5-10 sec mellanrum oavsett om motorn går på tomgång eller drar. Det blir inget ryck eller dragförlust utan varvtalet är jämt och fint. Ljudet låter som pistolskott. Under körning därefter är allt som det ska vara. Tändstiften byttes för ca 500 mil av SAAB-kunnig verkstad. Jag kan inte tänka mig att det är fel sorts tändstift eftersom verkstaden i lager använder typiska SAAB-delar som rätt Xenonlampor etc. Vevaxelgivaren är inte bytt. Motorn är aldrig öppnad. Och inga felkoder enl verkstaden. Om ljudet kommer från insug eller utblås kan jag inte avgöra.

  11. #11
    Steg 1
    Reg.datum
    nov 2012
    Inlägg
    1 628
    Jag skulle nog dubbelkolla stift och tändkassett trots att det är en ”Saab”
    Verkstad som bytt dom.


    Skickat från min iPhone med Tapatalk

    1 användare gillar detta inlägg



  12. #12
    Steg 6
    Reg.datum
    feb 2005
    Ort
    Stockholm
    Inlägg
    6 722
    Medlem#
    8758
    Det slog mig en annan sak, det skulle kanske kunna vara en läckande spridare som skickar ut bränsle antingen under avstängning eller när den står med resultat att det finns bränsle som skickas ut i avgassystemet omedelbart vid start om det sker innan det hunnit avdunsta.

    Borde gå att göra en del experiment för att kontrollera om så är fallet, där det mest uppenbara är att (med värmehandskar) kontrollera tändstiften omedelbart efter stopp med varm motor. Kanske även ger något om man kontrollerar efter stopp med kall motor, betydligt snällare mot händerna.
    9-5 2.3t SC 2000, 55000+ mil
    9000 CSE 2.3T -93
    9000 CSE 2.3t -96

  13. #13
    Steg 3
    Reg.datum
    apr 2009
    Ort
    Stockholm
    Inlägg
    3 026
    Medlem#
    11937
    Kolla de uppenbara och enkla sakerna först innan du börjar med tidskrävande, dyr och avancerad felsökning. D.v.s. kolla etiketten på tändkassettens undersida för modell, tillverkare och tillverkningsdatum. Sedan tar du ut tändstiften och kollar på dem (modell? Skick?)

    Även min helt enastående saabverkstad har missat en gång och monterat fel del.

    2 användare gillar detta inlägg


    Tidigare: Saab 900i -88, Saab 900i -89
    Nu: Saab 9-5 aero -04, Volvo S70 -98
    Härnäst: Ren elbil. Dagsnotering: Kia Niro EV

  14. #14
    Sugmotor
    Reg.datum
    mar 2009
    Inlägg
    20
    Tack för alla goda råd och övriga. Fortsättning följer med div undersökningar nästa år och jag hoppas återkomma med lösningen i början av januari.

Liknande ämnen

  1. [LÖST] CE vid start av varm motor T7 (P0113)
    Av HeRmAN i forum Motor och motorstyrning
    Svar: 0
    Senaste inlägg: 2007-07-24, 20:04
  2. 9-5 2,3t M99 me nordic steg2 tjurig vid start med varm motor
    Av 9-5-Staffan i forum Motor och motorstyrning
    Svar: 7
    Senaste inlägg: 2006-10-12, 07:08

Behörigheter för att posta

  • Du får inte posta nya ämnen
  • Du får inte posta svar
  • Du får inte posta bifogade filer
  • Du får inte redigera dina inlägg
  •