Resultat 1 till 16 av 16

Ämne: Kan inte vrida om tändningslås NG9-3 -03

  1. #1
    Sugmotor
    Reg.datum
    sep 2019
    Ort
    Uppsala
    Inlägg
    10
    Medlem#
    -

    Kan inte vrida om tändningslås NG9-3 -03

    Hej på er

    Då var de min tur att få problem med min NG9-3 bensin, manuell -03.
    SID/info-display säger Rattlåsfel, ABS problem, Bromsfel och Antispinn problem.
    Kan inte tända lyset, inte blinkers eller varningsblinkers. Inte slå på radion.
    Tänkte jag skriver ner de jag vet och gjort så att även andra får tips på hur dom kan gå till väga i felsökandet.

    På min NG9-3 går de inte att vrida runt nyckeln.
    Har provat båda nycklarna utan resultat.
    Har ett helt nytt batteri, så problem med spänningen ska de inte vara.
    Har mätt alla säkringar, ingen trasig. (Kollat säkringar vid A-stolpen och dom i motorutrymmet.)
    Har plockat loss alla relän. Alla fungerar.
    Drar jag en plus kabel från batteriet till startreläts utgång, så snurrar startmotorn.
    Tändningslås/ISM och CIM ska vara bland de vanligaste felen.
    Så beställde ett tändningslås/ISM (som enligt säljaren skulle fungera) på tradera, men nyckel går ändå inte att vrida.
    Har plockat isär tändningslåset (Lite bökigt, men inte svårt) och gjort rent kontaktstiften som ska glida mot kretskortet, men icke.
    Kanske vart lurade när jag köpte på Tradera, de tändningslåset kanske också var kass.
    Provade med en nyckel till en annan Saab, då kom de upp i SID/info-panelen att de var fel nyckel.
    Tändningslåset läser bara av nyckelns kodning, så där krävs ingen programmering.
    Hittade en kväll att en jordkabel mellan chassi och växellåda var av.
    Den som sitter bakom vänster framdäck. Verkar vara vanligt problem på Saab 9-3.
    Om man tar en fin platt skruvmejsel så kan man på undersidan av tändningslåset pilla undan en liten fjäder som gör så att de inte går att vrida nyckeln.
    Men pillar man undan den så kan man vrida nyckel ända till startläge. Men när jag gör de så snurrar inte startmotorn.
    Har provat att koppla upp olika OBD2 läsare (Billigare modeller) men dom får ingen kontakt med bilen.
    Vissa verkar kunna lösa sina problem genom att rycka ur och sätta tillbaka säkring 2 vid de säkringar som sitter innanför instrumentpanelen. Någon hade till om med satt en strömbrytare vid handbromsen som bröt kretsen för säkring 2. Så slapp han rycka ur den varje gång.

    Väntar på att en kille med Tech2 ska komma se om han kan få ut några felkoder.
    Misstänker att de är CIM som bråkar. Verkar vara ett vanligt fel på tidiga NG 9-3.
    Har hittat en på nätet med samma nummer som jag funderar på att köpa och gifta in.
    Funderar på om de blir störningar i spänningen när jordkabeln gick av. Kanske i värsta fall ECU'n som pajat. Hittade en killa på Youtube som visar hur man gifter ut gamla och gifter in den nya.
    MEN, när jag kollar på nätet hur man gör för att gifta in både ISM och CIM så ska man kunna vrida på nyckeln. Men de kan ju inte jag-
    Men de blir sista att testa. De finns även företag som kan laga ECU. Inte helt gratis, men kanske en sista utväg.
    Då skickar man iväg ECU'n till dom. Dom tar en kopia på mjukvaran. Lagar eller om dom har en likadan så laddar dom ner mjukvaran och testar enheten så att den fungerar.
    Tror tom att dom jag garanti på jobbet. Har för mig att de gick lös på ca 5000kr.
    Finns någon som bara gjorde åt företag, men de finns även de som gör till privatpersoner.

    Någon som har tankar eller idéer på vad man kan göra medans man väntar på killen med Tech2 ska komma?
    Om ni haft liknande problem, hur gick de för er?
    Läst en hel del här på forumet om liknande problem, för dom flesta verkar de räckt att byta tändningslåset.

    Tack på förhand.

    / Daniel

  2. #2
    Sugmotor
    Reg.datum
    sep 2019
    Inlägg
    2
    Medlem#
    -
    Har samma problem på min NG9-3 -09
    Har ingen lösning
    Blir bärgare till Saab i KBA nu på måndag
    Blir lite trixit att få den ur garaget
    Återkommer när rattlåsproblem är löst
    Peter

  3. #3
    Steg 1 daspunners avatar
    Reg.datum
    jan 2011
    Ort
    Varberg
    Inlägg
    1 209
    Fick ingen kontakt på OBD-porten så länge startspärren inte var släppt. Detta gällde en gammal 9000. Skulle inte bli förvånad om om det var det gör att du inte får kontakt med din bil heller. Inte för o måla fan på väggen men jag ser en chans att det kan uppstå problem när du väl får dit en Tech2, att du inte får kontakt då heller.
    SAAB 9-5 Kombi Aero MY07 Fusion blue

  4. #4
    Individuell mappning
    Reg.datum
    maj 2003
    Ort
    Trollhättan
    Inlägg
    7 677
    Medlem#
    6973
    Tech2 fungerar på 9-3SS även om det inte går att vrida runt nyckeln. Det går att tvinga bilen att tillåta att nyckeln vrids runt, och det är inga problem att felsöka. Läs felkoderna innan det beställs en massa delar.
    9000 A50 2.0t -97 bruksbilen
    9000 CSE 2.3T -95 pysselbilen
    9000 -85 projektet som spelar död

  5. #5
    Sugmotor
    Reg.datum
    sep 2019
    Inlägg
    2
    Medlem#
    -
    Problemet löst med rattlåsfel
    Det var rattlåset som var defekt .så nu sitter det ett nytt .fick tillbaka bilen dagen efter 5400kr blev det,ett stort plus till verkstaden ,

    1 användare gillar detta inlägg



  6. #6
    Steg 1 daspunners avatar
    Reg.datum
    jan 2011
    Ort
    Varberg
    Inlägg
    1 209
    Fasen om man får sån service kan 5400:- till och med kännas rimligt!
    SAAB 9-5 Kombi Aero MY07 Fusion blue

  7. #7
    Sugmotor
    Reg.datum
    sep 2019
    Ort
    Uppsala
    Inlägg
    10
    Medlem#
    -
    Hej igen,
    Kul att de löser sig för andra med liknande problem som jag har på min Saab.
    Senaste uppdateringen från mitt garage är att jag fortfarande väntar på killen som skulle komma med Tech2 och läsa felkoder.
    I väntat på de så kom de en annan vän över igår kväll med sin Autocom.
    Den lyckades läsa av en del felkoder som tex:
    C08000 Control Unit power supplay, value too low.
    U2103 TCE/ESP missing on Can-bus.
    C0121 Valve relay not close
    U2105 ECM (Control Unit Engine) missing on Can-bus.

    De tre översta gick att radera, men inte C0121 och U2105.
    De sitter ett helt nytt batteri i nu, så de var kanske en gammal felkod som låg kvar. Eller så är de dålig kontakt eller kabelbrott någonstans.
    Sökte runt lite på Google på felkoden U2105 och de verkar som att de kan vara CIM som kan spöka och så att de verkar som ECM inte fungerar.
    Ni får gärna rätta mig om jag har fel, men är CIM som en liten central som andra enheter kommunicerar genom/med?

    Fortsättning följer.

  8. #8
    Sugmotor
    Reg.datum
    sep 2019
    Ort
    Uppsala
    Inlägg
    10
    Medlem#
    -
    Fick lite tid med bilen igår kväll igen.
    Hittade några nya felkoder:
    B1000, Internal Control Module Random Access Memory (RAM) Error -Inttermittent.
    B2023, SIDC (Saab Information Display Controls) Incorrect. -Inttermittent.
    B3057, Control Unite Not Programmed -Permanent
    U2156, O-Bus (Optical Bus) Open Circuit -Permanent

    De flesta koder gick att radera, utom B3057
    Sitter och funderar på några olika spår just nu.
    1, CIM är kass. Verkar som en felande CIM kan generera konstiga följdfel.
    2, ECU är kass/Styrdon motor, På Youtube hittade jag en kille som hade B3057 som felkod. Han programerade om sin ECU sen fungerade bilen igen. Eftersom jag har U2105 ECM (Control Unit Engine) missing on Can-bus. Kabelbrott på spänning in?
    Tycker dock inte att ECU problem borde göra så att nyckeln inte går att vrida runt.
    3, Kabelbrott, Verkar inte helt ovanligt att kabelstammen har legat och nött mot något när man söker runt på nätet. Eftersom jag har C0800 Control Unit power supplay, value too low och U2105 ECM (Control Unit Engine) missing on Can-bus, om inte ECM har
    någon spänning in.

  9. #9
    Sugmotor
    Reg.datum
    sep 2019
    Ort
    Uppsala
    Inlägg
    10
    Medlem#
    -
    Problemen med min Saab fick en positiv vändning igår kväll.
    Har lagt en del tid på att googla på Saabar med liknande problem som jag.
    Hittade för ett tag sedan en kille som listat ut att han hade problem med sin säkringsbox bredvid batteriet.
    Igår kväll fick jag för mig att titta närmare på den.
    Så kopplande bort batteriet och började skruva. 2 skruvar med invändig torx och 3 st med utvändig torx och 1st 13mm mutter senare så var lådan lös.
    Säkringsboxen sitter påtryck på 3st kontaktstsycken på undersidan av boxen. Så de är bara att lyfta bort inkommande pluskabel som satt fast men 13m muttern. Så de är bara att lyfta rakt upp.
    En smart lösning av Saab ingenjörerna, men känns inte optimal om man tänker på hur fukt kan ta sig in.
    Klippte till små plastbitar av ett gammalt plastlock för att lägga mellan säkringsboxens ytterväggar och innanmäte. där sitter nämligen insidan fast med massor av hullingar.
    Väl inne i lådan så såg de spännande ut. Hittade ett kretskort som de var skyddslack på, men dom hade nog vart snåla på lacken ut i kanterna. och de hade varit fukt där inne också.
    Mätte lite av de som gick att komma åt, men hitta inget att anmärka på.
    Så plockade ihop allt igen och monterade tillbaka.
    När jag kopplar på batteriet så hoppade lyset plötsligt igång, de har inte hänt tidigare.
    Nyckeln gick inte att vrida runt, men efter att ha pillat undan låsningen på undersidan av tändningslåset så kan jag vrida på nyckeln.
    Då hoppade vindrutetorkarna igång, de har inte heller gått tidigare.
    De gick inte att starta med nyckeln.
    Men provade att plocka bort startrelät och lagt plusström på plinten för reläets utgång till startmotor så hoppade bilen igång, HURRA!!!...
    Kopplade upp felkodsläsaren och alla felkoder jag haft som inte gått att radera, gick nu att radera, HURRA igen!!!
    Så inga problem med ABS, Bromsfel och Antispinn. Men Rattlåsfel ligger kvar.
    Så nu är antalet potentiella felorsaker minimerade till ISM eller CIM.
    Sitter även och funderar på om man skulle kosta på sig en ny säkringslåda, antingen beg från skroten eller ny från tex Ebay.

    Fortsättning följer :-)

    Fusebox.png

    2 användare gillar detta inlägg


    Senast redigerat av Beetle_danne den 2019-09-19 klockan 07:54.

  10. #10
    Steg 1 daspunners avatar
    Reg.datum
    jan 2011
    Ort
    Varberg
    Inlägg
    1 209
    Vad föreställer bilden? Säkringsboxen du nämner?

  11. #11
    Sugmotor
    Reg.datum
    sep 2019
    Ort
    Uppsala
    Inlägg
    10
    Medlem#
    -
    Yes, de är kretskortet som finns inne i säkringsboxen.
    Eller egentligen är de flera kort som sitter ihop.
    Kretskortet innehåller allt från de kontaktstift som säkringar och relän trycks fast i.
    Men även de stift som trycks ner i kontakstyckena när man trycker ner säkringsboxen i bilen.
    Även bitar av korten har massa fastlödda komponenter.

  12. #12
    Sugmotor
    Reg.datum
    sep 2019
    Ort
    Uppsala
    Inlägg
    10
    Medlem#
    -
    Då vart de äntligen lite garagetid igen.
    De som hänt sen sist är att jag har fått låna en Tech2 med tillhörande laptop med TIS2000.
    Körde Remov på CIM som satt i bilen.
    Monterade bort den och monterade tillbaka den begagnade CIM'n som enligt tidigare ägare uppget att den ska fungera och var urgift.
    Den för mig nya CIM'n har samma Saab nr som min original CIM (128.00.181AA)
    Körde Add på den, och allt gick jättebra till efter jag tagit ut och stoppat i nyckeln ett antal ggr i tändningslåset.
    Då får jag "Add / Remove ECU failed" men ingen förklaring varför.
    Har gjort en handfull med försök att lägga till CIM igen, men utan resultat.
    Har provat med en av mina originalnycklar och även med nycken som hör till den andra CIM enheten.
    Provade då att lägga till gamla original CIM men de blev samma fel där.
    Har även provat att lägga till nyckel och att inte lägga till nyckel.
    Men de faller på samma steg varje gång.
    Funderar på om jag gör fel, eller om de är någon enhet som fortfarande inte får spänning från säkringsboxen.
    Och därför inte pratar med systemet.
    Fortsättning följer.
    Senast redigerat av Beetle_danne den 2019-09-29 klockan 11:13.

  13. #13
    Sugmotor
    Reg.datum
    sep 2019
    Ort
    Uppsala
    Inlägg
    10
    Medlem#
    -
    Då börjar denna historia närma sig slutet.
    Sökte på nätte i olika forum vad "Add / Remove ECU failed" kunde bero på.
    Hittade en kille i USA som haft exakt samma symptom som jag.
    Efter mycket arbete bytta han rattlåset, sen fungerade bilen igen.
    Så jag beställde ett rattlås jag med. Hittade ett begagnat på Bildelsbasen för 1500kr.
    Låset hade samma nummer som mitt, så jag tryckte på beställnings knappen.
    Fick hem tändningslåset igår kväll. så passade på att byta tändningslåset direkt.
    Raderade felkoder med Tech2 och körde Add CIM.
    Helt plötsligt så gick de hela vägen.
    Så bilen går att starta helt normalt igen.
    Så vad var felen egentligen.
    *Dålig kontakt i säkringsboxen vid batteriet i motorutrymmet.
    *Bytt CIM. (Oklart om den gamla verkligen var dålig. men den är bytt iaf).
    *Bytt rattlåset som sitter på styrstången.

    (Dock så startar inte radion. Funderar på om den inte får någon spänning.
    Tech2 säger problem med AMP1, CDF/CDCF och EHU. Men de ska nog lösa sig de också)

    Hoppas att de jag haft problem med och hur jag listat ut vilka problem bilen hade kan hjälpa någon annan med liknande problem.

  14. #14
    Individuell mappning
    Reg.datum
    maj 2003
    Ort
    Trollhättan
    Inlägg
    7 677
    Medlem#
    6973
    Du gjorde ingen Add SCL?
    9000 A50 2.0t -97 bruksbilen
    9000 CSE 2.3T -95 pysselbilen
    9000 -85 projektet som spelar död

  15. #15
    Sugmotor
    Reg.datum
    sep 2019
    Ort
    Uppsala
    Inlägg
    10
    Medlem#
    -
    Hej Hyvens, Bra fråga.
    Nej någon "Add" av SCL har jag inte gjort.
    Har iods inte kollat om SCL hoppar i när jag tar ut nyckeln.
    Ska ta och undersöka de innan jag lämnar tillbaka Tech2.
    Annars så kommer säker bilprovningen ha åsikter fall de rattlåset inte fungerar

  16. #16
    Sugmotor
    Reg.datum
    sep 2019
    Ort
    Uppsala
    Inlägg
    10
    Medlem#
    -
    Gjorde en Add på SCL här om kvällen. Igår var jag ute och körde bilen lite fram och tillbaka utanför garaget.
    När jag parkerade bilen och frog ur nycklen hoppade rattlåset i :-)
    Så nu verkar allt på de området att fungera.

    Skriv tidigare att jag hade problem med att få ljudet i radion att fungera. De är AMP1 under förarstolen som rostat sönder.
    Benen på några komponenter hade ärgat/tostat av.
    Provade att löda ihop komponenterna med de hjälpte inte.
    Fanns AMP1 på Bildelsbasen, men de var riktigt dyra.
    Efter lite googlande så gjorde jag som många andra.
    Drog försiktigt ut fiberkablarna och satte ihop dom riktade mot varandra med en bit vakuumslang.
    På så sätt blir kretsen sluten och radion börjar låta. Dock bara högtalarna i instrumentpanelen som låter.
    Så de blir mycket diskant i bilen tills jag hittar på en bra lösning.
    Namnlös.png

Liknande ämnen

  1. Tändningslås problem, kan inte vrida om nyckel. NG9-3 -06
    Av LPunderground i forum Ljud och elektricitet
    Svar: 12
    Senaste inlägg: 2017-09-10, 18:43
  2. Nyckel går ej att vrida runt i tändningslås, Saab 9-5 -00
    Av ArcTiC i forum Ljud och elektricitet
    Svar: 14
    Senaste inlägg: 2012-02-04, 10:33
  3. Går ej att vrida om tändningslås 9-5
    Av Mas95 i forum Ljud och elektricitet
    Svar: 8
    Senaste inlägg: 2011-11-22, 15:33
  4. [LÖST] Tändningslås hängt sig kan ej vrida runt nyckel. NG900
    Av progge i forum Ljud och elektricitet
    Svar: 4
    Senaste inlägg: 2006-07-10, 21:37
  5. [LÖST] Kan inte vrida om startnyckeln OG9-5
    Av Patrikk i forum Ljud och elektricitet
    Svar: 9
    Senaste inlägg: 2006-02-25, 15:17

Behörigheter för att posta

  • Du får inte posta nya ämnen
  • Du får inte posta svar
  • Du får inte posta bifogade filer
  • Du får inte redigera dina inlägg
  •