Resultat 1 till 4 av 4

Ämne: Omstartande mätarhus och plötsligt strömlöst NG9-3 -09

  1. #1
    Sugmotor
    Reg.datum
    maj 2016
    Ort
    Stockholm
    Inlägg
    2
    Medlem#
    -

    Omstartande mätarhus och plötsligt strömlöst NG9-3 -09

    Hej.
    Har en 9-3 1,8t BP -09 som under en tid (ca 1,5-2år) haft problem med att mätarhuset startat om (Typ självkontroll som när nyckel vrids om) under körning till och från, blinkers slutade fungera(I bilen iallafall då mätarhuset härjar fritt) under tiden den höll på men stereon gick som vanligt. Det hände ibland en gång under resan och i vissa fall mot senare tiden flera gånger på rad, sedan kunde allt vara bra mellan några timmar till flera veckor.

    Bilen har varit inne hos SAAB för felsökning nu i april-maj men då inga felkoder lagrades och mekaniker inte kunde få fram problemet själv under provkörning så var allt han fick ut att CIM gav interna felsignaler och KUNDE vara problemet, så den byttes.
    Efter besöket var allt bra någon månad tills felet började återkomma igen och har blivit värre och oftare för att ibland helt slå av i 20-30 sekunder. Känns som vid regn och kyla var problemen värre, men kan ha varit sammanträffande.

    Nu i söndags 7/7 startade bilen som vanligt och jag började köra iväg men reagerar när jag slagit igång blinkers att mätarhuset har slocknat. Jag stannar då till och provar vrida av tändningen och sedan på nytt vrida på tändningen men ingen reaktion från varken mätarhus eller startmotor, surret från bränslepumpen hördes iallafall första försöket. Efter 4-5 försök att vrida av och på tändningen hoppar allt igång igen och jag kunde köra hem (ca 8mil) utan besvär.
    Läste ut felkoderna via eSID och fick fram dessa från CIM:
    B3981 00 - PDM saknas på bussen eller ej tillagd, immobiliseringskoden från PDM saknas.
    B3979 00 - BCM saknas på bussen eller ej tillagd, immobiliseringskoden från BCM saknas.
    B3978 00 - MIU saknas på bussen eller ej tillagd, immobiliseringskoden från MIU saknas.

    Det som gjorts på bilen mer än div service och slitage är att monterat larm hos SAAB (Sätta dit huvkontakt och koda in med tre misslyckade försök och samtal till trollhättan så gick det på fjärde.), bytt spegelglas 2017 (Från avbländande till icke avbländande = En sladd som inte längre kopplas in, kan ge elfel?) av mig själv, bytte batteri då det gamla var helt slut (Laddar nu runt 13,7-14, start volt på 10,1), bytte tredjebromsljus själv 2017 och byte av vindruta på Glasfirma 2018.
    Jag har dessutom själv bytt låskista HB för 3-4 månader sedan.
    Andra problem är backsensorerna är ur funktion, jord bruten till alla fyra sensorer,(Glappade först men dog helt tillslut för kanske 3 år sedan) och solenoid tanklucka kortsluten -2016 (men brukar fungera som det ska)


    Dålig ISM eller MIU var min tanke då CIM redan är bytt, men med senaste felen och felkoderna känns det mer som ISM eller något med kablarna, typ glapp.
    Har beställt en beg. ISM som är påväg hem då den inte behöver giftas in.

    Finns det annat jag bör kolla på och utesluta? och hur gör jag det på bästa sätt? eller bara några andra tankar?

    VH Stefan

  2. #2
    Steg 2
    Reg.datum
    aug 2009
    Inlägg
    2 928
    Jag tror på glapp eller temporär kortslutning av I-bussen. Att MIU stängs av gissar jag är något problem med kraftmatning eller jordning av MIU alternativt internt fel i MIU. Bara gissningar, jag har ingen liknande erfarenhet men den bilen är (som många andra moderna bilar) full av elspöken i aldrig sinande ström. Mycket beror på dålig kvalité hos kontaktdon och kablage.

    CIM har I-buss ansluten i tre riktningar, mot diagnosuttaget, mot MIU och via en crimp-skarv som förgrenar bussen i ytterligare tre riktningar varav en går via airbagstyrdonet till BCM. Enligt översiktsschemat i WIS går det även att nå BCM via elcentralen i motorrummet och den bakre elcentralen samt ytterligare ett par skarvar.

    I första hand skulle jag leta i närheten av där det har gjorts försök till reparationer och bytts delar. Undersök kontaktdon mot CIM och MIU samt kablage däremellan. Finns det några klämda kablar eller skadade kontaktstift/hylsor. Undersök kablage där huvkontakten anslöts samt övrigt kablage/don till larmet. I-bussen går även till styrdonet i bakdörren där du mekat.

    Med Tech2 kan man ”pinga” alla styrenheter i bilen och få ledtrådar till var felet kan finnas t ex genom att pinga och röra vid kablage där det kan vara glappt. Det finns felräknare i alla styrenheter vilka kan läsas ut med Tech2 och ge ledtrådar.

    Kretschemor och beskrivningar finns i WIS, Workshop Information System. Det är inte tillåtet att kopiera skärmbilder från WIS och lägga upp här.

    Någon tipsade nyligen om en fritt tillgänglig WIS på webben. Dock tycks den inte vara komplett.

    T ex här: https://saabwisonline.com/b6/9-3/200...s-and-i-bus-2/
    händer det inget när man klickar på pilarna i vänstra marginalen. I "riktiga" WIS kommer det upp förklarande bilder när man klickar på motsvarande pilar.

    Rutan märkt 703 här är CIM:
    https://saabwisonline.com/images/9440/img-f8/f8i11.jpg

    Här fungerar det att klicka på pilen i vänstra marginalen.
    https://saabwisonline.com/b6/9-3/200...description-2/
    Där syns vilka styrdon som kommunicerar via I-bus respektive P-bus med CIM som översätter mellan bussarna.

    ISM tror jag inte så mycket på med den här felbilden men den är ju enkel att byta och jag kan såklart ha fel.

    Lycka till och berätta här hur det går!
    9-3 Aero 2000, 9-3 Aero SS 2005, BMW R1100RS 1993, tidigare 9000 CDi 1989, 900i 1985, 96 V4 1972

  3. #3
    Sugmotor
    Reg.datum
    maj 2016
    Ort
    Stockholm
    Inlägg
    2
    Medlem#
    -
    Tack för svar!

    Ska absolut kolla upp lite mer med kablar och kontakter på diverse ställen som du rekommenderar och som står om i länkarna. Väldigt intressant läsning hur systemen fungerar och kommunicerar vilket efter lite snabb genomläsning verkar mer troligt som orsak med glapp eller liknande på i-bussen vilket alla moduler med felkod är del av. Även eSID brukar SID slänga ut mig ifrån och kan vara då det uttaget även är kopplat till i-bus. WIS har jag på datorn hemma så kan gå igenom det nu när jag vet vad jag kollar efter, tech2 däremot får jag försöka klara mig utan för tillfället.
    Är rätt ny till el biten i fordon så kommer nog ta lite tid att gå igenom och förstå hur allt fungerar och hur ledningarna är dragna, men nu vet jag vart jag ska börja leta och kolla efter.

    Uppdaterar såklart här när jag kommer fram till något!

  4. #4
    Steg 2
    Reg.datum
    aug 2009
    Inlägg
    2 928
    Då du har "riktiga" WIS så rekommenderar jag att du läser där framför saabwisonline som jag länkade då den inte verkar vara komplett.
    9-3 Aero 2000, 9-3 Aero SS 2005, BMW R1100RS 1993, tidigare 9000 CDi 1989, 900i 1985, 96 V4 1972

Liknande ämnen

  1. Strömlöst dragkroksuttag NG9-3 -07
    Av CurtLjungberg i forum Ljud och elektricitet
    Svar: 4
    Senaste inlägg: 2018-05-08, 07:17
  2. Strömlöst
    Av morganm i forum Motor och motorstyrning
    Svar: 5
    Senaste inlägg: 2015-04-30, 08:54
  3. Radio code efter bilen strömlöst Saab 9-5
    Av toorp i forum Ljud och elektricitet
    Svar: 10
    Senaste inlägg: 2014-12-10, 19:22
  4. Måste larmet kodas om vid strömlöst i ng900?
    Av bart112 i forum Ljud och elektricitet
    Svar: 1
    Senaste inlägg: 2006-10-29, 10:14
  5. Mätarhus
    Av Death On Wings i forum Ljud och elektricitet
    Svar: 4
    Senaste inlägg: 2005-09-14, 20:53

Behörigheter för att posta

  • Du får inte posta nya ämnen
  • Du får inte posta svar
  • Du får inte posta bifogade filer
  • Du får inte redigera dina inlägg
  •