Resultat 1 till 17 av 17

Ämne: Ny generator men SID säger "Batteriet laddas ej kontakta verkstad" NG9-3

  1. #1
    Sugmotor
    Reg.datum
    feb 2019
    Inlägg
    5
    Medlem#
    -

    Ny generator men SID säger "Batteriet laddas ej kontakta verkstad" NG9-3

    Hej,
    Ny på forumet, behöver lite hjälp..
    Har en Saab 9-3 2.0t, 2004. ca 16600mil

    Bilen började varna för låg kylarvatten nivå - fyllde på, felet kvarstod.
    Bilen varnade för att antisladd var ur funktion, sen kom varningen för ABS ur funktion. Sen dog bilen..
    Bogserade hem bilen, laddade batteriet, allt ok. Antar att dessa felmeddelanden kom pga för låg spänningsnivå i systemet.

    Mätte litegrann och kom fram tilll att generatorn inte laddade. Min lokala verkstad rekomenderade att byta hela generatorn, inte bara laddningsregulatorn då det oftast vara några dioder i generatorn som gett upp.
    Då jag är osäker på om jag skall ha kvar bilen eller ej så gick jag på billigaste alternativet och köpte en ny generator från skruvat.se, landade på 1500kr ungefär.
    Monterade in den nya generatorn i helgen, allt gick fint. Men nu får jag felmedelandet "Batteriet laddas ej kontakta verkstad". Mäter jag på batteriet så har jag 14,5V på batteriet när bilen är igång så det verkar ju vara okay.
    Lite intressant är att detta meddelande visades inte när den gamla generatorn satt i och inte laddade..

    En kollega med ODB2 läsare kollade men hittade inga felkoder i bilen.

    Behöver en ny generator giftas in i bilen på något vis?
    Andra idéer?

    Mvh David
    Senast redigerat av David_J den 2019-02-12 klockan 10:37. Anledning: Fel kategori.

  2. #2
    Steg 5
    Reg.datum
    feb 2006
    Ort
    Torpshammar
    Inlägg
    5 287
    Nej det ska inte behövas nå mer än att bara montera den. Man får ju göra lite mer mätningar. Troligen är det väl dålig kontakt nånstans.

  3. #3
    Individuell mappning
    Reg.datum
    maj 2003
    Ort
    Trollhättan
    Inlägg
    7 291
    Medlem#
    6973
    Låter som att det är fel på L- eller F-Term. Borde finnas en felkod.

    Hittade en snarlik tråd:
    http://forum.saabturboclub.com/showt...9-3-SS-B207-04

    Tror det löste sig den gången med en annan generator.

    Mvh
    9000 A50 2.0t -97 bruksbilen
    9000 CSE 2.3T -95 pysselbilen
    9000 -85 projektet som spelar död

  4. #4
    Sugmotor
    Reg.datum
    feb 2019
    Inlägg
    5
    Medlem#
    -
    Tycker att jag kontrollerat allt. Kollat så att jord är okay osv.. Lite märkligt..

  5. #5
    Sugmotor
    Reg.datum
    feb 2019
    Inlägg
    5
    Medlem#
    -
    Tack för länken, helt klart väldigt likt problem. Till saken hör att jag köpte en 120Amp och org troligen var 140. Trodde dock att det inte skulle spela ngn roll då jag inte har en massa lull-lull i form av stereo och extraljus etc.. Vore ju surt att behöva beställa en till...
    Well, skall kolla om det kanske kan finnas nån mjukvara då det stod i länken att från 2005 så hade bilarna 120Amp generatorer.

  6. #6
    Sugmotor
    Reg.datum
    maj 2018
    Ort
    Södra Sandby
    Inlägg
    8
    Medlem#
    -
    Jag har provat en ATL-generator från Skruvat till min 06:a, oem 12757363. Fick samma fenomen trots korrekt laddning. Visade sig att ATL-regulatorn inte var kompatibel. Returnerade och fick utan problem alla pengar tillbaka.
    Tips är originalrenoverade från Speedparts eller lågmilad från bildemontering.
    Mvh Håkan
    9-3 SC 1.8T Steg 1 - 2006

  7. #7
    Steg 5
    Reg.datum
    feb 2006
    Ort
    Torpshammar
    Inlägg
    5 287
    När det gäller moderna bilar kan man inte blanda och ge hur som helst "som förr" Det är mycket elektronik inblandat och det övervakas och styrs av databox osv osv. Man bör noggrant titta vad man har först och utgå från det.

    1 användare gillar detta inlägg



  8. #8
    Steg 5
    Reg.datum
    feb 2006
    Ort
    Torpshammar
    Inlägg
    5 287
    Har suttit och kikat igenom alla varianter på dessa och tidiga 140A ersätts av 120A även original så det är inte fel på det viset. I det stora hela är det bara en regulator också på alla typer. Saab säljer bara en och även om det skiljer på någon från bosch så är det bara en ytterst liten spänningsskillnad. Alla fungerar på samma sätt med DFM och L terminal. Ingen skillnad på årsmodeller alltså.
    Tittar man på bildelsbasen så skriver dock en del på de nyare 2005 och uppåt "avkodad" vad nu det innebär..........

  9. #9
    Grundladd
    Reg.datum
    feb 2017
    Ort
    Uppsala
    Inlägg
    156
    Medlem#
    -
    Har du provat byta till ett
    annat batteri?

  10. #10
    Sugmotor
    Reg.datum
    feb 2019
    Inlägg
    5
    Medlem#
    -
    Tack för alla svar. Ledsen att jag försvunnit, tänkte att det är dax att återkoppla lite.
    Provade ett annat batteri. Problemet kvarstår.
    Lyckades returnera den nya generatorn. Skickade min gamla till en klassisk bilelektricitetsfirma som bytte regulator och testade den i sin testbänk. Nu funkar den prima enl firman. Perfekt nu skall vi få fart på bilen igen.
    Idag monterade jag dit min renoverade generator. Bilen gick fint, inga felkoder, men efter ca tio minuter tändes varningslampa för bromsar och nån mer. Precis som när hela den här soppan startade. Stängde av bilen för att starta om den - stendöd.
    Laddade upp batteriet, startade bilen, fram med multimetern. Laddar noll..
    varningslamporna var troligen pga låg spänning.
    Lite tröttsamt...
    Hittar inga trasiga säkringar. Har mätt direkt på generatorn.
    Någon klurig som har nån idé?
    God kväll

  11. #11
    Helt original
    Reg.datum
    maj 2003
    Ort
    ANNELÖV / SKÅNE
    Inlägg
    569
    Skall bli spännande, samma fel på dotterns TTID -08. Jag bytte till en Bosch fabriksny generator vid ca 19000 mil.
    Nu har bilen gått 26000 mil och nu tändes det upp "laddar ej" bilen gick tills den dog för att försöka komma hem med den.
    Jag mötte upp satte i ett ok batteri och körde hem den men samma meddelande kom direkt vid start.
    Mäter man med multimeter laddade generatorn ingenting. Har köpt billigaste 140 amp från Auto doc i tyskland för 1600 kr samt en extra laddregulator.
    Blir som sagt spännande i morgon när jag skall byta och se hur det går.

  12. #12
    Sugmotor
    Reg.datum
    feb 2019
    Inlägg
    5
    Medlem#
    -
    Äntligen kan jag rapportera att problemet är löst!
    Det var frihjulet som strulade på originalgeneratorn. Förmodligen har bilelektrikerfirman som körde den i bänk inte använt frihjulet utan drivit generatorn på splinesen inne i frihjulet eller nåt. Såg ej när de körde. Kan varmt rekommendera firman bildetaljer AB i Helsingborg, det var dom som löste problemet.
    Jag och min far har nu efter 3 demontage/montage av generatorn blivit rätt kvicka på det momentet. Det går fint att ta den ovanifrån om man plockar bort några kylslangar. Man behöver alltså inte ta den verkstadshandbokrekommenderade vägen via hjulhuset.

    1 användare gillar detta inlägg

    bka


  13. #13
    Steg 5
    Reg.datum
    feb 2006
    Ort
    Torpshammar
    Inlägg
    5 287
    Man testar inte generatorer med rem överhuvudtaget. De flesta provbänkar har direktdrift in på mutter eller splines. Det man ska komma ihåg med dessa frihjulskopplingar är att INA som gör de flesta OEM hjul rekommenderar byte vid 10k mil. Hur många gör det........

  14. #14
    Individuell mappning
    Reg.datum
    maj 2003
    Ort
    Trollhättan
    Inlägg
    7 291
    Medlem#
    6973
    Frihjulet var trasigt som att det det var kontinuerligt frikopplat?
    9000 A50 2.0t -97 bruksbilen
    9000 CSE 2.3T -95 pysselbilen
    9000 -85 projektet som spelar död

  15. #15
    Helt original
    Reg.datum
    maj 2003
    Ort
    ANNELÖV / SKÅNE
    Inlägg
    569
    Ja då kom paketet från tyskland. Givetvis fel generator!
    Tog kontakt med en lokal bilels firma och beställde en ny från dom.
    Den gamla kommer dom att test köra i bänk förmodligen i morgon.
    Eftersom batterilampan tänds i instrumentet så utgår jag från att det finns kontakt hela vägen från anslutningskabeln
    på generatorn upp till just glödlampan. Ger sig i morgon när den nya generatorn kommer.

    - - - Uppdaterad - - -

    Ja då kom paketet från tyskland. Givetvis fel generator!
    Tog kontakt med en lokal bilels firma och beställde en ny från dom.
    Den gamla kommer dom att test köra i bänk förmodligen i morgon.
    Eftersom batterilampan tänds i instrumentet så utgår jag från att det finns kontakt hela vägen från anslutningskabeln
    på generatorn upp till just glödlampan. Ger sig i morgon när den nya generatorn kommer.

  16. #16
    Steg 5
    Reg.datum
    feb 2006
    Ort
    Torpshammar
    Inlägg
    5 287
    Citat Ursprungligen postat av Hyvens Visa inlägg
    Frihjulet var trasigt som att det det var kontinuerligt frikopplat?
    nu svarar jag generellt men dylika frihjulskopplingar slits på samma vis som ett startmotordrev och blir de precis på gränsen att det kanske är slitet och det kommer nå skit i dem så kan de driva ibland och rätt vad det är få för sig att inte driva. Att frihjulet inte spärrar ibland alltså. Den vanliga haveriorsaken annars är ju att de går torr och havererar fullständigt. Då brukar de ramla isär och annat roligt.

    1 användare gillar detta inlägg



  17. #17
    Helt original
    Reg.datum
    maj 2003
    Ort
    ANNELÖV / SKÅNE
    Inlägg
    569
    Ny generator på plats och allt fungerar igen. 'Den gamla laddade ingenting vid bänkkörning.

Liknande ämnen

  1. Batteriet laddas inte NG9-3
    Av Poppelito i forum Ljud och elektricitet
    Svar: 10
    Senaste inlägg: 2017-05-18, 12:24
  2. Batteriet laddas ur på min 9-5 ´98
    Av nikos@tsiourdinis.se i forum Ljud och elektricitet
    Svar: 5
    Senaste inlägg: 2013-01-09, 21:34
  3. Koppla bort batteriet när det laddas?
    Av pestor i forum Ljud och elektricitet
    Svar: 6
    Senaste inlägg: 2012-12-04, 10:22
  4. Batteriet laddas ur
    Av ola89 i forum Ljud och elektricitet
    Svar: 2
    Senaste inlägg: 2008-08-24, 13:20
  5. Batteriet laddas ur när bilen är igång
    Av Rikard i forum Ljud och elektricitet
    Svar: 6
    Senaste inlägg: 2005-05-24, 19:06

Taggar för det här ämnet

Behörigheter för att posta

  • Du får inte posta nya ämnen
  • Du får inte posta svar
  • Du får inte posta bifogade filer
  • Du får inte redigera dina inlägg
  •