Sidan 3 av 4 FörstaFörsta 1234 SistaSista
Resultat 41 till 60 av 75

Ämne: Automatisk taxikoppling för NG9-3: Det funkar!!!

  1. #41
    Steg 3 Mr.Os avatar
    Reg.datum
    nov 2004
    Inlägg
    3 744
    Medlem#
    ja
    Citat Ursprungligen postat av zimm Visa inlägg
    motstånd i omkopplaren. Måste vara då för att kunna detektera ett avbrott ^^ känns onödigt invecklat för något så enkelt. Typiskt saab

    Sedan kan man sätta en typisk felkod "avbrott eller kortslutning" (trots att man vet vilket det är...
    §99CC74900T81,§9000T86,§9-5 03,†9-5 02,§9-5 02, *9000Aero 95, *9-3 04, *9-5 09,*9-5 09
    White,Svart,Odoardogrå, Silver, CosmicBlue, CosmicBlue, LeMansBlå, LaserRed, Laserröd, CarbonGrey

  2. #42
    Citat Ursprungligen postat av whiskeycola Visa inlägg
    Härligt Norrbagge! Då är min slutsats korrekt!
    Jo då, jag kan titta i WIS.
    Hur går projektet?
    Lite nyfiken

    Skickat från min SM-G935F via Tapatalk

    1 användare gillar detta inlägg


    9-3 SC Areo V6 2,8 (A6) XWD - 2009

  3. #43
    Steg 1 whiskeycolas avatar
    Reg.datum
    maj 2016
    Ort
    Gävleborg
    Inlägg
    1 595
    Medlem#
    10853
    Jo tack, det avstannade lite under senvintern.

    Men nu har jag spenderat de senaste tre kvällarna med att löda ihop mitt prototypkort.

    IMG_4700x.jpg IMG_4701x.jpg IMG_4702x.jpg

    Så nu i helgen kan jag testa funktionen.
    Femtioelva gånger under tiden som detta blev gjort kände jag för att bara chansa och beställa kort.
    Ungefär så här.
    Mvh Johan

    93 Aero Coupé -00 • 93 Turbo X SC • 93X BioPower XWD -10
    Tidigare: 99 GL -84 • 9000 Aero -96 • 93 Aero XWD SC -08 • 95 Aero SC -06 • 93 2.0t Linear SC -06

  4. #44
    Steg 1 whiskeycolas avatar
    Reg.datum
    maj 2016
    Ort
    Gävleborg
    Inlägg
    1 595
    Medlem#
    10853
    Någonstans mellan teoretiserandet och praktiserandet har det blivit tokigt.
    Kopplade in 12V för att mäta på pinnarna innan jag trycker dit arduinon, och det stämmer inte riktigt.
    Pinne 4 från bildatorn kommer med 12V för belysningen, och det var ju där jag tänkt känna av om man har slagit på tändningen.
    Men jag har gjort något fel med motstånden för jag får 12V ända fram till arduino-pinnen.
    Skall granska alltihop igen. Är rätt säker på att jag har blandat ihop något på elschemat.

    1 användare gillar detta inlägg


    Mvh Johan

    93 Aero Coupé -00 • 93 Turbo X SC • 93X BioPower XWD -10
    Tidigare: 99 GL -84 • 9000 Aero -96 • 93 Aero XWD SC -08 • 95 Aero SC -06 • 93 2.0t Linear SC -06

  5. #45
    Grundladd
    Reg.datum
    mar 2017
    Ort
    Stockholm
    Inlägg
    126
    Medlem#
    -
    Jävla intressant projekt. Ser fram emot fortsättningen

  6. #46
    Steg 1 whiskeycolas avatar
    Reg.datum
    maj 2016
    Ort
    Gävleborg
    Inlägg
    1 595
    Medlem#
    10853
    Med de senaste dagarnas skitväder har det inte blivit någon rostlagning på OG9-3:an, och MapTuns coilover-kit till Turbo X:en lyser med sin frånvaro.
    Så då är det ju perfekt att ta tag i detta igen!

    Programmeringen är löst, och jag har ett nytt, mycket större, prototypkort som funkar på bänken. Betydligt mer lättjobbat och mer genomtänkt än det där lilla kortet jag visade bild på tidigare.
    Drog om lite i kretsschemat, vet inte vad jag tänkte förut.
    Lätt att bli hemmablind...

    Nu måste jag trippelkolla alla motståndsvärden/spänningsnivåer mot WIS, kontrollmäta kontakten i bilen 2-3 gånger till, och se till att allt är hyfsat rätt.
    Sedan ska jag bara bestämma om det är bruksbilen (9-3X) eller racerbilen (Turbo X) som skall få vara labbråtta.
    Vet inte om det är intressant med bilder eller så? Ni får hojta till i så fall...

    1 användare gillar detta inlägg

    gbg

    Senast redigerat av whiskeycola den 2018-05-01 klockan 19:16.
    Mvh Johan

    93 Aero Coupé -00 • 93 Turbo X SC • 93X BioPower XWD -10
    Tidigare: 99 GL -84 • 9000 Aero -96 • 93 Aero XWD SC -08 • 95 Aero SC -06 • 93 2.0t Linear SC -06

  7. #47
    Steg 3 Mr.Os avatar
    Reg.datum
    nov 2004
    Inlägg
    3 744
    Medlem#
    ja
    Klart det är intressant med all info om detta. Bilder oxo, såklart!
    §99CC74900T81,§9000T86,§9-5 03,†9-5 02,§9-5 02, *9000Aero 95, *9-3 04, *9-5 09,*9-5 09
    White,Svart,Odoardogrå, Silver, CosmicBlue, CosmicBlue, LeMansBlå, LaserRed, Laserröd, CarbonGrey

  8. #48
    Steg 1 whiskeycolas avatar
    Reg.datum
    maj 2016
    Ort
    Gävleborg
    Inlägg
    1 595
    Medlem#
    10853
    Ok!
    Här är den färdiga prototypen.

    IMG_4828.jpg

    Grått är minus/jord, lila är +5V från regulatorn och orange är signaler/sense.
    Plintarna i botten är, vänster till höger:
    J1 (2p, 12V in)
    J2 (8p, ut till ljusvred)
    J3 (8p, in från bildatorn)

    Det blev lite skillnader eftersom jag kopplat fel. Vi får väl se om jag tänkt rätt.
    Det fungerar i alla fall med ljusvredet inkopplat.
    Tändning känns av via instrumentbelysningen på pinne 4, via spänningsdelare.
    Jag tror att det var så jag tänkt från början, men allt eftersom kretskortet tog form lyckades jag blanda ihop pinnar och funktioner.
    I och med det försvann ett motstånd (R1).

    schema.jpg

    Och här är ljusinställningarna jag tänkt mig.
    En rak kopia av taxikoppling på OG9-3/9-5.


    ljusinst.jpg

    2 användare gillar detta inlägg


    Senast redigerat av whiskeycola den 2018-05-03 klockan 19:36.
    Mvh Johan

    93 Aero Coupé -00 • 93 Turbo X SC • 93X BioPower XWD -10
    Tidigare: 99 GL -84 • 9000 Aero -96 • 93 Aero XWD SC -08 • 95 Aero SC -06 • 93 2.0t Linear SC -06

  9. #49
    Steg 1 whiskeycolas avatar
    Reg.datum
    maj 2016
    Ort
    Gävleborg
    Inlägg
    1 595
    Medlem#
    10853
    Nu har jag provat den i bilen. Det blev 9-3X:en som fick ställa upp.

    Och... Det funkar! Inte.

    Verkade nästan som att Arduinon resettade hela tiden. Xenonlamporna blinkade av och på.
    Jag får ta och labba med att skicka in exakt samma spänningsnivåer på J3 för att se hur den beter sig.
    Kan också vara det att jag knytit ihop alla jordpunkter. Kanske måste dela på det så att 12V-matningen har separat jord.
    Skulle kunna prova genom att mata spänningsregulatorn från pinne 4 och på så sätt isolera kretsen fårn extern matning.
    Men jag vet inte om man kan dra mer än dioderna kräver från pinne 4...

    Bilen varnar i alla fall inte för fel, och allt funkar som det ska när jag plockat bort grejorna.
    Senast redigerat av whiskeycola den 2018-05-04 klockan 18:34.
    Mvh Johan

    93 Aero Coupé -00 • 93 Turbo X SC • 93X BioPower XWD -10
    Tidigare: 99 GL -84 • 9000 Aero -96 • 93 Aero XWD SC -08 • 95 Aero SC -06 • 93 2.0t Linear SC -06

  10. #50
    Steg 3 Mr.Os avatar
    Reg.datum
    nov 2004
    Inlägg
    3 744
    Medlem#
    ja
    Som IT-konsulten sade: "Men bortsett från att det inte fungerar, vad tycker du om lösningen?"
    Ser väl bra ut!

    Jag skulle misstänka spikar på 5V.
    För att minska spikarna kan man testa med att koppla av med kondensatorer till jord på regulatorn (7805 ?). Tex typ 1000uF elyt på ingången, 100uF elyt på 5v ut, samt dessutom en 0,1uF keram eller polyester parallellt med varje elyt. Det bör ge en "snyggare" 5V.

    Orsaken till blinkandet skulle kunna vara att Xenon lampornas drivenheter ger spikar på 12volten när de tänds, som stör arduinon så mycket att den resettas och därmed släcker Xenon. När arduinon restartar blir det samma om och om igen...

    2 användare gillar detta inlägg


    §99CC74900T81,§9000T86,§9-5 03,†9-5 02,§9-5 02, *9000Aero 95, *9-3 04, *9-5 09,*9-5 09
    White,Svart,Odoardogrå, Silver, CosmicBlue, CosmicBlue, LeMansBlå, LaserRed, Laserröd, CarbonGrey

  11. #51
    Steg 1 whiskeycolas avatar
    Reg.datum
    maj 2016
    Ort
    Gävleborg
    Inlägg
    1 595
    Medlem#
    10853
    "Det gick inte så fort, men så blev det inte så bra heller"

    Bra tips. Ska kolla vad exakt som händer lite noggrannare imorgon.
    Tyckte inte det såg ut som att Arduinon resettade men det var i princip så belysningen betedde sig.

    Vid test så matade jag kretsen via cigguttaget vid instrumentpanelen. Borde väl ha ungefär samma jordplan som BCM (bildatorn som styr bl.a. belysning)
    Men jag kan prova att klippa kopplingstråden som bryggar minusanslutningarna på kortet som ett första steg.
    Och kanske prova att koppla in allt utan själva arduinon, för att se hur verkligheten ser ut på J2/J3 och pinnarna fram till arduinon.

    Har ju ett serviceuttag för 5V på kortet, så jag kan styra transistorerna manuellt.
    Mvh Johan

    93 Aero Coupé -00 • 93 Turbo X SC • 93X BioPower XWD -10
    Tidigare: 99 GL -84 • 9000 Aero -96 • 93 Aero XWD SC -08 • 95 Aero SC -06 • 93 2.0t Linear SC -06

  12. #52
    Steg 1 whiskeycolas avatar
    Reg.datum
    maj 2016
    Ort
    Gävleborg
    Inlägg
    1 595
    Medlem#
    10853
    Jag tror jag har hittat felet.
    Har lött fel. Motstånden R8-R11 sitter i serie med transistorerna, ej parallellt
    Mvh Johan

    93 Aero Coupé -00 • 93 Turbo X SC • 93X BioPower XWD -10
    Tidigare: 99 GL -84 • 9000 Aero -96 • 93 Aero XWD SC -08 • 95 Aero SC -06 • 93 2.0t Linear SC -06

  13. #53
    Steg 1 whiskeycolas avatar
    Reg.datum
    maj 2016
    Ort
    Gävleborg
    Inlägg
    1 595
    Medlem#
    10853
    Mvh Johan

    93 Aero Coupé -00 • 93 Turbo X SC • 93X BioPower XWD -10
    Tidigare: 99 GL -84 • 9000 Aero -96 • 93 Aero XWD SC -08 • 95 Aero SC -06 • 93 2.0t Linear SC -06

  14. #54
    Grundladd Naminos avatar
    Reg.datum
    okt 2017
    Ort
    Piteå
    Inlägg
    457
    Medlem#
    11785
    Så jävla sant ungefär som jag skrek ut högt för världen efter lite mek blev ett litet topplockspacknings byte

    /Tapatalk
    Saab 9 Aero Hirsch -04 | Saab 9³ 2.0t Polar -02(Reservdelshögen) Nu med Tech2

  15. #55
    Steg 1 whiskeycolas avatar
    Reg.datum
    maj 2016
    Ort
    Gävleborg
    Inlägg
    1 595
    Medlem#
    10853
    Ja det är väldigt tillfredsställande när något man jobbat med går bra.

    Nästa steg blir att rita om kortet och beställa ett par fabriksgjorda prototyper.
    Så att man kan köra med det i bilen utan att ha ett kluster med kablar vid vänster knä.
    Sen måste jag bestämma hur och var jag ska ta 12V. Kanske finns det en ledig säkringsplats i centralen innanför förardörren som man kan använda. Annars får det bli någon lösning med hängsäkring på kabeln.

    1 användare gillar detta inlägg


    Mvh Johan

    93 Aero Coupé -00 • 93 Turbo X SC • 93X BioPower XWD -10
    Tidigare: 99 GL -84 • 9000 Aero -96 • 93 Aero XWD SC -08 • 95 Aero SC -06 • 93 2.0t Linear SC -06

  16. #56
    Steg 3 Mr.Os avatar
    Reg.datum
    nov 2004
    Inlägg
    3 744
    Medlem#
    ja
    Citat Ursprungligen postat av whiskeycola Visa inlägg
    Jag tror jag har hittat felet.
    Har lött fel. Motstånden R8-R11 sitter i serie med transistorerna, ej parallellt
    Värst vad de var tjatiga de där motstånden. Löda om sig själva så på det viset allihopa!

    Nu får du köra en vecka test!
    §99CC74900T81,§9000T86,§9-5 03,†9-5 02,§9-5 02, *9000Aero 95, *9-3 04, *9-5 09,*9-5 09
    White,Svart,Odoardogrå, Silver, CosmicBlue, CosmicBlue, LeMansBlå, LaserRed, Laserröd, CarbonGrey

  17. #57
    Steg 1 whiskeycolas avatar
    Reg.datum
    maj 2016
    Ort
    Gävleborg
    Inlägg
    1 595
    Medlem#
    10853
    Ja de har bjudit på mycket motstånd...

    Förlängt test kan nog bli möjligt om jag, i väntan på fabrikskort, gör ett mindre som kan passa innanför ljusvredet. Det som är nu är lika stort som ett CD-fodral, så det är väldigt otympligt. Med en massa långa kablar, och matning från cigguttaget. Så som det matas med 12V just nu funkar det inte när tändningen är av, men det är ju enkelt att fixa.
    Mvh Johan

    93 Aero Coupé -00 • 93 Turbo X SC • 93X BioPower XWD -10
    Tidigare: 99 GL -84 • 9000 Aero -96 • 93 Aero XWD SC -08 • 95 Aero SC -06 • 93 2.0t Linear SC -06

  18. #58
    Steg 1 M.Brobergs avatar
    Reg.datum
    maj 2008
    Ort
    Halmstad
    Inlägg
    1 748
    Kul att det funkar!

    Jag som inte hängt med ordentligt på funktioner, kan du sammanfatta lite lätt vad mockapjäxen faktiskt Gör?
    jag har försökt fatta hur det fungerar med resultatet att jag nu inte fattar vad jag fattade tidigare. En Reset helt enkelt.

  19. #59
    Steg 1 whiskeycolas avatar
    Reg.datum
    maj 2016
    Ort
    Gävleborg
    Inlägg
    1 595
    Medlem#
    10853
    Hahaha! Okej.

    Du kör ju en NG9-3, så du vet hur drygt det är.
    Om man bara vill köra på positionsljus och dimljus så måste man, efter varje start av bilen, vrida ljusvredet till positionsljus-läget (klockan halv två) och trycka på dimljusen.
    Och när man kört klart och vill kliva ur måste man antingen vrida ljusvredet till 0 eller till halvljusläget (klockan tolv) så att inte positionsljusen är på hela tiden.

    Min mackapär styr om signalerna från ljusomkopplaren så att positionsljus och dimljus automatiskt slås på när tändningen slås på.
    Och när tändningen slås av så slås belysningen av.
    Detta sker när vredet är i 0-läget (klockan tre)

    Sen när det blir mörkt ute får man så klart slå på halvljuset genom att vrida ljusvredet rakt upp.

    1 användare gillar detta inlägg


    Mvh Johan

    93 Aero Coupé -00 • 93 Turbo X SC • 93X BioPower XWD -10
    Tidigare: 99 GL -84 • 9000 Aero -96 • 93 Aero XWD SC -08 • 95 Aero SC -06 • 93 2.0t Linear SC -06

  20. #60
    Steg 1 whiskeycolas avatar
    Reg.datum
    maj 2016
    Ort
    Gävleborg
    Inlägg
    1 595
    Medlem#
    10853
    Förtydligande bild (kanske?)

    omkopplare.jpg

    Det är nr 2 och 4 som är det viktiga.
    Lite dålig bildkvalitet med forumets nedskalning, så jag länkar till imgur också.


    Senast redigerat av whiskeycola den 2018-05-05 klockan 21:56.
    Mvh Johan

    93 Aero Coupé -00 • 93 Turbo X SC • 93X BioPower XWD -10
    Tidigare: 99 GL -84 • 9000 Aero -96 • 93 Aero XWD SC -08 • 95 Aero SC -06 • 93 2.0t Linear SC -06

Liknande ämnen

  1. Svar: 15
    Senaste inlägg: 2017-09-20, 12:15
  2. Dimljus istället för halvljus på dagen / Taxikoppling
    Av K-spring i forum Ljud och elektricitet
    Svar: 48
    Senaste inlägg: 2015-12-22, 23:04
  3. Xenon-dimljus Taxikoppling på ng9-3
    Av Fredrik / 1941 i forum Ljud och elektricitet
    Svar: 0
    Senaste inlägg: 2012-02-08, 14:39
  4. Automatisk elbakruta
    Av mrbeach i forum Ljud och elektricitet
    Svar: 1
    Senaste inlägg: 2008-02-24, 19:33
  5. AS3 Automatisk volymreglering? OG9-5
    Av suburban i forum Ljud och elektricitet
    Svar: 5
    Senaste inlägg: 2007-11-26, 23:57

Behörigheter för att posta

  • Du får inte posta nya ämnen
  • Du får inte posta svar
  • Du får inte posta bifogade filer
  • Du får inte redigera dina inlägg
  •